OK
AJAX error!

Les forumsGrammalecteIncompatibilité avec Mac ?

Incompatibilité avec Mac ?

Contrairement à la version 0.0.11, les versions suivantes sont incompatibles avec Mac pour une raison inconnue. Le code ne contient rien de spécifique concernant les OS. Tout est supposé être générique.

Ne possédant pas de Mac, il m’est difficile d’isoler le problème.

Un connaisseur en Python possédant un Mac pourrait facilement trouver le bug, car il y a eu peu de modifications de code entre la version 0.0.11 et les suivantes.

Si quelqu’un veut se donner la peine de trouver l’origine du bug, les version 0.0.11 et 0.0.12 sont ici :
www.dicollecte.org…
www.dicollecte.org…
le 04 octobre 2011 à 14:43
Bonjour,

D'après un petit test rapide aujourd'hui,

La version Grammalecte 0.1.1 fonctionne avec LibreOffice 3.5 beta 2 sur MacOS Leopard (10.5) intel

imageshack.us…

Quelqu'un peu confirmer ?
le 16 janvier 2012 à 10:47
bonjour,

je suis sous Mac OS X Lion et la nouvelle version de Grammalecte ne fonctionne toujours pas. Pouvez vous remettre les liens vers les anciennes versions SVP ?

Merci beaucoup.
le 20 janvier 2012 à 17:59
J’ai rétabli les liens. Merci pour le retour.
le 23 janvier 2012 à 14:13
Bonjour,

Merci pour votre réponse rapide, je vous indiquerai à l'avenir si les futurs versions de Grammalecte fonctionnent sur Mac OS X Lion.
le 23 janvier 2012 à 19:12
Bonjour,
Chez moi sa fonctionne avec LibreOffice 3.5 finale et Grammalecte 0.1.2
Sur MacOS X Lion (10.7)

imageshack.us…
le 23 février 2012 à 15:42
D’après ce qu’on me rapporte, sur Mac OS, Grammalecte 0.2 fonctionne avec LibreOffice mais pas avec OpenOffice.
le 04 septembre 2012 à 15:50
Bonjour,
LibreOffice 3.6.1 a encore plein de bugs sur Mac, mais Grammalecte 0.2 fonctionne bien chez moi avec MacOS Lion 10.7.4.
Si ca ne marche pas avec OOo, mon petit doigt me dit que ca a un rapprot avec la version de Python (ou l'extension qui s'appel "Fournisseur de scripts pour Python)
le 06 septembre 2012 à 15:00
Toutes les versions de Grammalecte sont incompatibles avec Apache OpenOffice 3.4.x sur Mac OS, attendu que la version de Python de cette version a régressé (2.3.5 au lieu de la 2.6.1 nécessaire).
le 27 octobre 2012 à 13:02
Bonjour,

Ayant utilisé des PC au cours des derniers mois, je viens de récupérer mon mac et j'ai voulu ajouter Grammalecte à mon installation d'OpenOffce, mais à ma grande déception j'obtiens un message d'erreur suivant :
img189.imageshack.us…
Visiblement, comme vous l'avez dit dans votre précédent message c'est un problème avec Python, mais j'ai du mal à comprendre d'où celui-ci provient. D'après cette page du site d'Oo : wiki.openoffice.org… la version actuelle de Python inclue avec la suite serrait 2.6.1 mais ils n'est pas précisé si cela concerne toutes les constructions (celle pour Mac pourrait être différente j'imagine).
J'utilise OpenOffice 3.4.1 (daté du 13 Août 2012) et je cherche à ajouter Grammalecte version 0.2.4.
Pouvez-vous m'en dire un peu plus sur la dépendance de Grammalecte sur Python, est-ce que le vérificateur est une extension écrite en python, ou bien est-ce simplement le processus d'installation qui utilise ce langage?
Je pourrais peut-être chercher une solution mais actuellement j'ai un peu de mal à comprendre vers où chercher...
Merci d'avance.
Mark.
le 23 janvier 2013 à 03:43
Bonjour,

Grammalecte est totalement écrit en Python. Pour une raison inconnue, OpenOffice a régressé sur la version de Python incluse (un problème de build probablement), uniquement sur Mac, passant de la version 2.6.1 à la version 2.3.5.
Le rapport de bug : issues.apache.org…

Les dévs d’Apache ne semblent pas intéressés par la correction de ce bug, attendu qu’ils prévoient d’inclure une version plus récente de Python, la 2.7, dans OpenOffice 4.0, prévue je ne sais quand.

LibreOffice, quant à elle, a migré vers Python 3.3. A priori, il ne devrait pas y avoir de problèmes majeurs pour maintenir Grammalecte compatible avec les deux logiciels, sous réserve que LO 4 ne modifie pas son API (ce qui est déjà fait, mais c’est peut-être un bug).

Je dois dire que ce bordel sans fin me casse les pieds, et que si ça continue ainsi, je n’hésiterai pas à laisser de côté ce qui m’ennuie.
le 23 janvier 2013 à 10:11
Bonjour,

Après multes bidouillages et recherches je n'ai pas réussi à forcer OO à charger une autre version de python (ce qui pourtant, devrait au moins en théorie être possible...) Sous OS X et OpenOffice 3.4 l'utilisation de Grammalecte reste donc impossible.
J'ai donc pris le parti d'abandonner cette suite dont le développement en plus de piétiner semble avoir fait des choix assez étranges, et je suis passé à LibreOffice, pour lequel Grammalecte et le multi-dictionnaire s'installent sans le moindre problème.
A quand une version d'OO corrigeant la rétrogradation de python sur Mac? D'ici là, je resterai sur LO...
Merci en tout cas pour l'aide sur ce point.
le 10 février 2013 à 09:41

Notification par e-mail    0