OK
AJAX error!

Les forumsTribune libreDéploiement, mise à jour des dictionnaires et Grammalecte

Déploiement, mise à jour des dictionnaires et Grammalecte

Bonjour,
si je suis hors du champ de ce site, ne pas hésiter à me le dire...

voilà, je déploie libreoffice dans mon lycée, sur environ 700 machines et c'est long au démarrage de la machine, un élèves peut être tenté d’interrompre le processus, ce qui a parfois pour effet de bloquer le processus de déploiement de la machine (il faut alors passer sur cette machine pour la nettoyer manuellement)

je ne mets à jour libreoffice qu'une fois par an. prochainement, je vais déployer la 3.4.4

autant que je sache, cette version ne contient pas la dernière version des dictionnaires et ne contient pas grammalecte.

or je sais faire des pacquages (ensemble de fichiers) à déployer sous XP ou seven

ma question est donc :

pour mettre à jour le dictionnaire, est ce que l'on doit simplement mettre à jour les fichiers du dictionnaire (et pas aussi des fichiers qui seraient ailleurs). et ce que la version du dictionnaire est alors changée dans le gestionnaire d'extension.

ma seconde question :

comment installer grammalecte ?
avant, il suffisait de mettre une extension dans un répertoire spécial d'installation des extensions. elles étaient alors automatiquement installées lors l'installation d'openoffice. cette possibilité a disparu avec la 3.2 je crois

donc, est ce que le simple fait d'ajouter le répertoire de l'extension suffit ?

merci
le 28 octobre 2011 à 15:33
Bonjour,

Je ne connais presque rien en matière de déploiement.

pour mettre à jour le dictionnaire, est ce que l'on doit simplement mettre à jour les fichiers du dictionnaire (et pas aussi des fichiers qui seraient ailleurs). et ce que la version du dictionnaire est alors changée dans le gestionnaire d'extension.


Vous pouvez copier les fichiers .dic et .aff par-dessus ceux inclus dans OOo/LibO. Ça ne pose aucun problème. (Je fais moi-même souvent ainsi.) En revanche, les informations mentionnées dans l’extension seront encore celles de l’ancienne version. Pour corriger ça, vous devez aussi mettre à jour description.xml et package-description.txt. Mais ne touchez pas à dictionaries.xcu, car l’organisation de l’extension incluse dans OOo/LibO n’est pas la même que celles proposées au téléchargement.

comment installer grammalecte ?
[…], est ce que le simple fait d'ajouter le répertoire de l'extension suffit ?


Je l’ignore. Demandez sur le forum francophone des utilisateurs.
le 28 octobre 2011 à 15:54

Vous pouvez copier les fichiers .dic et .aff par-dessus ceux inclus dans OOo/LibO. Ça ne pose aucun problème. (Je fais moi-même souvent ainsi.)



dans le répertoire de l'extension du dictionnaire français, les fichiers sont :

fr.aff et fr.dic alors que les noms des dictionnaires 4.3 sont fr-moderne.aff et fr-moderne.dic. doit laisser les noms de la v 4.3 ou ceux de libo ?
le 30 octobre 2011 à 16:19
Les nouveaux fichiers doivent remplacer les anciens. —> fr.dic + fr.aff
le 30 octobre 2011 à 16:26
merci,

je suis en train de faire différents tests...

une question, je suis donc en train de préparer le déploiement de libo 3.4.4 + dictionnaire + gammalecte, si tout va bien.

il n'y a pas une nouvelle version des dictionnaires ou de grammalecte pour les prochaines semaines ? ;o)

pierre

le 30 octobre 2011 à 16:43
en fait, j'ai tout simplement copié le contenu de l'extension dans le dossier extensions de libo, ainsi, j'ai bien les dictionnaires en 4.3, qui s'affichent en 4.3 et grammalecte 0,1

youpi !
le 30 octobre 2011 à 16:58
Pas de dictionnaire prévu prochainement.
Pour Grammalecte, je peux fournir une version un peu modifiée, mais pas testée. Je ne m’en occupe pas vraiment en ce moment.
le 30 octobre 2011 à 18:29
comme vous voulez,

ce que serait bien, se serait d'avoir l'option qui corrige les apostrophes désactivée par défaut, car je ne sais pas comment activer la substitution dans tous les comptes (je suppose que c'est dans le profil de l'utilisateur) mais si copie brutalement un fichier de config libreoffice dans tous les comptes, je risque de détruire des options perso....
le 30 octobre 2011 à 18:51
Pour ça, il faut désactiver l’option Typographie.

Dans lightproof_opts_dicollecte_fr_FR.py, remplacez :

lopts_default['fr_FR'] = [u'typo', u'esp', u'tu', u'maj', u'num', u'conf', u'sgpl', u'gn', u'gv', u'imp', u'inte', u'bs', u'pleo']


par :

lopts_default['fr_FR'] = [u'esp', u'tu', u'maj', u'num', u'conf', u'sgpl', u'gn', u'gv', u'imp', u'inte', u'bs', u'pleo']

le 30 octobre 2011 à 19:02
je vais le faire

merci !
le 30 octobre 2011 à 20:39
et c'est fait, et ça marche parfaitement. et c'est même fait avec la 3.4.4 rc2

merci beaucoup
le 04 novembre 2011 à 20:31
Bonjour,

j'ai donc créé un fichier msi pour installer l'extension grammalecte par GPO

est ce que vous m'autorisez à diffuser cette extension ?

merci

pierre
le 09 novembre 2011 à 14:00
Oui, bien sûr. :)
le 09 novembre 2011 à 16:43
Bonjour Pitpit,
je serais intéressée par votre fichier msi pour installer grammalecte par GPO, pour mon collège, où le diffusez-vous ? merci d'avance.
le 07 janvier 2012 à 14:10
il est ici : msicreteil.free.fr…

j'attends la nouvelle version de grammalecte pour mettre à jour dictionnaire et grammalecte
le 08 janvier 2012 à 17:56
Nouvelle version de Grammalecte prévue en fin de semaine.
le 08 janvier 2012 à 19:04
Merci !
le 08 janvier 2012 à 20:03

Notification par e-mail    0