OK
AJAX error!

Les forumsGrammalecteCorrection indésirable sur zones de texte non françaises

Correction indésirable sur zones de texte non françaises

Bonjour,

il peut arriver, dans des textes contenant des formules mathématiques, que l'on désactive la correction de l’orthographe sur sur une partie de texte. ce qui revient à définir aucune langue pour cette partie du texte.
grammalecte continu à rechercher des fautes de grammaire, est-il possible de faire de même (désactiver la correction grammaticale pour des partie de texte.
Ou bien est il possible d'envisager une évolution de grammalecte qui ne corrigerai pas le texte sans langue définie ?

merci

pierre
le 15 janvier 2012 à 21:01
Bonsoir,

Normalement, quand aucune langue n’est affectée à une zone de texte, le correcteur grammatical ne vérifie pas. Chez moi, c’est ainsi que ça fonctionne.
le 15 janvier 2012 à 21:15
le comportement est bizarre.

exemple ci dessous :

On a vu : P = Ueff.Ieff.cos(φ)
P est la puissance active, elle s’exprime en Watt

si je mets que l'équation sans langue, l'équation reste corrigée.

si je mets toute la phrase, de même

par contre si je mets les deux lignes, alors pas de correction de grammaire...

par contre, si je fais marche arrière, en remettant le français partout, sauf sur l'équation, et bien plus de correction...

et si joue un peu (français, pas de langue) au bout d'un moment, c'est toujours corrigé, sauf si je vais prendre la phrase précédente, pour ne plus mettre de langue...

et si je remets français partout sauf pour l'équation, c'est bon...

par contre, s'il n'y a qu'une équation sur la ligne, le comportement est bon. (sauf on joue et alors, c'est toujours corrigé, et là, je n'arrive à faire marche arrière....)
le 16 janvier 2012 à 18:03
Effectivement. Le problème vient du fait que le correcteur grammatical reçoit les paquets paragraphe par paragraphe. Donc, apparemment, il suffit que le paragraphe débute en français pour que le correcteur reçoive l’ensemble du texte, même s’il n’est pas intégralement en français.

Il faut remonter ce problème à LibreOffice, car je ne pense pas pouvoir agir à mon niveau. Grammalecte ne décide pas des paquets de texte qu’il reçoit. OOo/LibO envoie les paquets au correcteur qui renvoie les erreurs qu’il a trouvées.
le 16 janvier 2012 à 18:20
OK, je vais essayer de faire remonter le bug, mais je ne suis pas optimiste.
En fait l'option langue dans les styles de caractère, ne devrait peut être pas exister...
le 16 janvier 2012 à 21:59

Notification par e-mail    0