OK
AJAX error!

Les forumsGrammalecteInstallation : com.sun.star.uno.RuntimeException

Installation : com.sun.star.uno.RuntimeException

Bonojur.

Il m'est impossible d'installer Grammalect sur LibO - Win 7 x64

La Passerelle Python-UNO est installée (mais peut-être pas activée).
À l'installation, j'ai le message :

(com.sun.star.uno.RuntimeExecption) { { Message = ":[Errno 2] No such file or directory:

Suivit de l'emplacement où est installée Grammalecte.

Que faire, merci d'avance.
le 01 février 2012 à 00:04
Bonjour,

J’utilise moi-même Windows 7 64 bits et ne rencontre aucun souci.
À mon avis, c’est probablement le profil qui est corrompu. Effacez-le et relancez l'application.
le 01 février 2012 à 09:41
Déjà tenté de supprimer mon profil LibreOffice, ainsi qu'une désinstallation/effacement profil/ré-installation/intall_dico/intall_Grammalect.

Rien n'y fait.
le 02 février 2012 à 23:18
en relisant le message d'erreur dans son intégralité, j'ai pensé à un truc sur le fait qu'il ne trouve pas le fichier ou dossier.
(com.sun.star.uno.RuntimeExecption) { { Message = ":[Errno 2] No such file or directory:
u'C:\\\\Users\\\\MaSession\\\\AppData\\\\Roaming\\\\LibreOffice\\\\3\\\\user\\\\uno_packages\\\\cache\\\\uno_packages\lu324ru.tmp_\\\\Grammalect%20v0.1.2.oxt\\\\Lightproof.py',


Il garde comme emplacement d'installation, le nom du fichier originel "Grammalect v0.1.2.oxt" mais place le %20 (correspondant à l'espace).
J'ai renommé mon fichier en "Grammalect_v0.1.2.oxt" et ça marche.
Votre dico se fiche de porter un espace, mais pas Grammalect.
le 02 février 2012 à 23:35
Curieux. Il ne devrait pas y avoir d’espace dans le nom des extensions ! car les fichiers que je propose au téléchargement n’en ont pas.

C:\Users\[login]\AppData\Roaming\LibreOffice\3\user\uno_packages\cache\uno_packages\lu6rwkq.tmp_\ooo-dictionnaire-fr-moderne-v4.4.1.oxt

C:\Users\[login]\AppData\Roaming\LibreOffice\3\user\uno_packages\cache\uno_packages\luz9ip.tmp_\Grammalecte-v0.1.2.oxt



Me trompé-je en supposant qu’il y a un signe diacritique dans votre nom d’utilisateur ?
C’est une source courante d’ennuis pour tout ce qui concerne le profil d’OOo/LibO.
le 03 février 2012 à 01:34
En effet, le fichier proposé en téléchargement ne possède pas d'espace, c'est moi qui l'avais rajouté afin de mieux organiser mes fichiers sur mon ordinateur.

Quant au signe diacritique dans mon "nom d’utilisateur", non, ce n'est pas mon cas.


Curiosité : Pourquoi votre Dictionnaire Modern, contrairement à Grammalect, n'est pas affecté par cet espace ?
le 03 février 2012 à 16:12
Le dictionnaire est mis en mémoire par un procédé différent (du C++ qui lit un fichier de configuration en XML).
Pour Grammalecte, c’est apparemment le code Python de la passerelle Python-UNO qui ne sait pas gérer cet espace.
le 03 février 2012 à 16:20
Bonjour, je réutilise le même sujet car l'erreur semble la même ? je suis sous Ubuntu 15.04 (en béta donc) libreoffice Version: 4.4.1.2 et j'ai l'erreur suivante hpics.li… ...
le 29 mars 2015 à 00:16
Je ne pense pas que l’erreur soit la même.
Ce message est toujours aussi mystérieux. Erreur inconnue.

Je vois que votre fichier s’appelle “Grammalecte-v0.4.8(1).oxt”. Renommez en ôtant ce “(1)” et réessayez. Mais il n’est pas du tout dit que ce soit la même cause.

Faisiez-vous fonctionner une version précédente de Grammalecte sur votre système ?

En général, le meilleur moyen d’éviter le sac de nœuds des distributions, c’est d’installer la version officielle de LibreOffice. Les versions packagées par les distributions ne sont pas fiables, car elles sont modifiées, leur comportement est donc altéré de manière inconnue.
le 29 mars 2015 à 10:03

Notification par e-mail    1