OK
AJAX error!

Les forumsGrammalecteFormateur de texte : bugs de remplacement $1

Formateur de texte : bugs de remplacement $1

Je ne sais pas si c'est là qu'il faut signaler les bugs, mais bon.

Sous Windows 7 64 bits, dernière version de LibreOffice 4.4, le >Formateur de texte me fait des trucs bizarres il m'introduit ceci :
espace insécable$1esapce insécable 
apparemment à la place de certains espaces insécables.

Par exemple, ceci : «Hands up!»
devient « Hands up $1 »

Cela me la fait dans des documents en français comme celui-ci (oui je sais ça ne se voit pas) et en anglais mais ça semble lié à un contexte que Grammalecte ne reconnaît pas comme du français.
le 15 avril 2015 à 12:14
Je viens de tester, et je reproduis effectivement le problème. Mais c’est LibreOffice qui bogue, en fait, ou plus exactement probablement la librairie ICU qui semble complètement défaillante. C’est vraiment casse-pied.

Je vais voir ce que je peux faire pour contourner le problème.
le 15 avril 2015 à 12:34
Et bien sûr le site d’ICU est inaccessible en ce moment.
Cela dit, je viens de voir que des patchs sur ICU ont été ajoutés à LibreOffice dernièrement.

J’ai quand même procédé à des contournements de bugs dans le code de Grammalecte.
le 15 avril 2015 à 13:17
Et avec la toute dernière version de LibreOffice, la 4.4.3.1, c'est encore plus ennuyeux. Dans un texte en fançais il remplace les :

qu' (apostrophe moche)

par $1 ce qui donne :

"Même, tandis $1’il voyageait en Amérique"

Et, ça c'est nouveau, le «Hands up!» est correctement corrigé. Je ne pense pas qu'il soit utile de bidouiller Grammelecte en état.
le 17 avril 2015 à 10:20
J’ai quand même refait des modifications.
le 17 avril 2015 à 14:35
Je confirme les remplacements de :
qu' par $1
Grammalecte : 5 2 3 (0 4 7 1)
LO : 4 4 4 3
OS X : 10 10 4
le 12 août 2015 à 19:35
C’est la version 0.4.9 qui corrigeait ce problème… :)
le 12 août 2015 à 20:31
Je rencontre le même problème avec:
LO : 5.1.4.2
Grammalecte : 0.4.10.7 et 0.5.7
Linux Debian Jessie (la version LO est celle de jessie-backports)
le 08 juillet 2016 à 17:03
Je ne reproduis pas le problème sous Windows.
C’est toujours la librairie ICU qui pose problème. Pouvez-vous essayer avec la version officielle de LO et non celle de votre distribution, s’il vous plaît ?
le 08 juillet 2016 à 19:51
Moi je suis sur OS X 10.11.5 avec LO 5.1.4.2 et Grammalecte 0.5.7 et je n'ai pas ce souci.
«Hands up!» et «qu'» sont bien corrigé en « Hands up ! » et « qu’».
le 08 juillet 2016 à 20:14
J'ai téléchargé la version officielle de LO 5.0.6 et en effet, aucun problème avec celle-là.
C'est donc un problème avec la librairie ICU de Debian jessie-backports...
le 09 juillet 2016 à 09:42

Notification par e-mail    2