OK
AJAX error!

Les forumsGrammalecteUtiliser Grammalecte et LanguageTool en même temps

Utiliser Grammalecte et LanguageTool en même temps

Bonjour bonjour !
En général, j’écris en français. Et incontestablement, Grammalecte est l’outil qui me convient le mieux, et de loin. Impossible de m’en débarrasser d’un revers de la main. Pour ça, d’ailleurs, merci beaucoup.
Mais parfois, voir assez souvent, j’écris de l’anglais et de l’allemand. Et là, malheureusement, il n’y a pas 36 solutions, c’est LT. Alors je connais la réponse officielle : non Grammalecte et LT en même temps c’est pas possible. Mais j’ai vu traîner quelque part que "pas en même temps pour la même langue".
Alors je me demandais s’il n’y avait pas une grosse bidouille qui permettrait d’avoir Grammalecte quand le texte est en français, et LT pour les autres. D’autant qu’il y a possibilité dans LibreOffice dans les options linguistiques de décocher des outils pour certains langages en particulier... sauf que si Grammalecte y est bien listé quand il est installé, quand je le remplace par LT, ce dernier n’y apparaît pas.
Pour le moment, en général je me passe de LT, et de temps en temps, je désinstalle le paquet Grammalecte pour celui de LT et quand j’ai fini, je fais la manip inverse, pas très pratique. Même si je pourrais me faire un petit script pour ça, il y a peut être mieux à faire ? Peut être un fichier dans LT à modifier pour qu’il ne s’enregistre pas pour les textes en français ?
Cordialement,
Cilyan
le 18 janvier 2016 à 21:39
Bonjour,

Plutôt que de d’installer/désinstaller les extensions, avez-vous essayé l’option "Désactiver/Activer" d’une extension ?

Pierre
le 18 janvier 2016 à 22:14
Bonjour,

Pour être précis, oui, il est possible d’installer Grammalecte et LanguageTool en même temps. Cependant, lorsque les extensions s’installent, elles déclarent chacune de quelle(s) langue(s) elles vont se charger. Si plusieurs extensions déclarent s’occuper d’une langue, je ne sais plus très bien ce qui se passe, car j’ai essayé il y a trop longtemps, mais grosso modo une seule va remporter la mise, la première installée, la dernière installée, peut-être même que ça change au démarrage de Writer et selon les versions, je ne me souviens plus. Cela est dû à la manière d’enregistrer les extensions.

Bref… aucune fiabilité de fonctionnement garantie.

J’ignorais que LT n’était pas désactivable dans les options linguistiques. Je ne peux rien faire pour ça.

En revanche, oui, puisque vous parlez de script, vous êtes assez geek pour suivre une procédure qui devrait solutionner le problème. :)

Désinstallez LT. Fermer LO.
Ouvrez l’oxt de LT. Ouvrez le fichier Linguistic.xcu avec un éditeur de texte. C’est dans ce fichier XML que LanguageTool déclare les langues dont il veut prendre le contrôle. Elles sont déclarées sous forme d’un code-langue, comme fr-FR, fr-BE, etc.
Supprimez tous les codes en fr-XX. Rezippez l’extension.
Ouvrez LO. Réinstallez LT.
Fermez LO et relancez.

Éditer ces fichiers directement dans le profil de LO, ça ne fonctionnera pas (je crois), attendu que lors de l’installation, ces données sont copiées et réutilisées ailleurs, dans le complexe registre de LO. C’est pourquoi il faut suivre une procédure de réinstallation.

Parfois toutes les réinstallations successives d’extensions corrompent le profil. Repartir sur un profil propre ne peut pas faire de mal non plus.

Je n’ai jamais essayé, mais ça devrait fonctionner. Dites-nous ce qu’il en est.
le 19 janvier 2016 à 11:27
Bonsoir,
Ah bah voilà, ça marche très bien ça ! Ben ça fait plaisir, ça faisait un moment que je me passais souvent de correction en anglais et en allemand par flemme.
i.imgur.com…

Par contre, j’ai bien enlevé toutes les langues françaises du fichier XML, mais j’ai quand même l’impression que d’une manière ou d’une autre, LT se déclare à LibreOffice comme supportant le français. Du coup, il faut activer manuellement Grammalecte et désactiver LT :
i.imgur.com…

Et il y a bien LT dans les options linguistiques, en fait je tourne sous Arch et depuis la version 3.2-1 LT ne marche qu’avec le JRE8 officiel d’Oracle. En fait, l’extension enregistrait bien ses menus, mais elle était corrompue. Mea culpa, j’ai pas fait attention.

Pour ceux que ça intéresse: gist.github.com…

Merci pour votre aide en tous cas, sur cette question mais aussi surtout tous les jours pour mes rédactions ! :)
le 20 janvier 2016 à 01:43
Je ne comprends pas comment concilier le fait que ça marche «très bien» et celui qu’il vous faut quand même désactiver l’un ou l’autre pour qu’il n’y ait pas interférence. :)

Je pense que vous devriez demander conseil sur le forum de LT, vous aurez peut-être un complément d’informations utile.
forum.languagetool.org…
le 20 janvier 2016 à 02:48

J’ignorais que LT n’était pas désactivable dans les options linguistiques.


LT et Grammalecte sont bien désactivables (sans les désinstaller). Depuis le menu principal :
Tools → Extension Manager… Puis si on clique sur l’extension (LT ou Grammalecte), il y a un bouton pour désactiver et un autre bouton pour supprimer l’extension. Le bouton pour désactiver devrait fonctionner. C’est plus facile que de désinstaller.
le 20 janvier 2016 à 10:47
@dominiko : On parlait de la désactivation dans le menu Outils > Options > Paramètres linguistiques > Linguistique. Mais apparemment ce n’était qu’un problème de profil corrompu.

@Cilyan: Je réalise qu’il peut aussi y avoir un problème entre LT et Lightproof qui est inclus par défaut pour l’anglais. Il faut désactiver LT pour l’anglais ou Lightproof. Même problème éventuellement avec le russe et le portugais.
le 20 janvier 2016 à 17:21
Salut, je viens de faire une demande sur leur forum, on verra ce que ça donne.

forum.languagetool.org…
le 21 janvier 2016 à 10:56
Pour le moment, je suis satisfait. En fait, la désactivation (ou pour être plus précis, la sélection) se fait une bonne fois pour toute, c’est ça qui me convient bien. En fait, ce n’est pas l’extension entière que je désactive ou que je désinstalle, mais c’est juste dans les options linguistiques sélectionner le bon correcteur grammatical et vérifier qu’il n’y en a qu’un seul de sélectionner. Pour le moment, pas de soucis en anglais avec LightProof. Dans les options linguistiques, il n’y a que l’option LanguageTool de disponible et d’activée. Ceci dit, en voyant la capture d’écran du post sur le forum de LT, je me demande si ce n’est pas tout simplement parce que l’extension n’est pas installée chez moi. Ma distribution, ArchLinux, a l’habitude de faire des paquets le plus léger possible en séparant les fonctionnalités dont tout le monde n’a pas obligatoirement besoin. Mais je dis peut-être une bêtise, parce que je ne trouve pas de paquet supplémentaire avec LightProof dedans. Enfin, en tous cas ça marche, et dnaber qui a répondu à shunesburg69 sur le forum LT a l’air de penser lui aussi que les deux extensions peuvent parfaitement coexister si tant est que les paramètres sont corrects.
le 24 janvier 2016 à 02:15
Lightproof s’installe en théorie avec les dictionnaires anglais, portugais et russe. Sur Linux, effectivement, c’est plus dur de savoir ce qui se passe.

Cela dit, si vous avez ôté les locales françaises que LT enregistre comme siennes dans le fichier de configuration Linguistic.xcu, vous ne devriez avoir rien à faire. Il ne devrait pas être nécessaire de cocher/décocher des cases dans les options le LibreOffice.

Sauf erreur de ma part.

C’est pour ça que je vous avais suggéré de poser la question chez LT. Il y a peut-être un fonctionnement de LT que j’ignore, mais la demande de shunesburg69 sur leur forum n’est pas assez spécifique. :)
le 24 janvier 2016 à 11:34
Désolé de ne pas avoir donné trop de détails, ne connaissant pas le problème moi-même, j’ai signalé le problème pour gagner du temps et faciliter la main de Cilyan.
le 25 janvier 2016 à 11:06

Notification par e-mail    1