OK
AJAX error!

Les forumsGrammalecteInstallation impossible de la version 0.5.17.1

Installation impossible de la version 0.5.17.1

Bonjour

Plus moyen d'installer Grammalecte sur LibreOffice. L'installation de la version 0.5.17.1 ou la réinstallaton de la 0.5.17 précédente échouent avec ce message d'erreur:

"ImplementationRegistration::registerImplementation() - The service com.sun.star.loader.Python cannot be instantiated"

Version: 5.3.4.2
Build ID: 5.3.4-1
Threads CPU : 4; Version de l'OS :Linux 4.11; UI Render : par défaut; VCL : gtk2; Moteur de mise en page : nouveau;
Locale : fr-FR (fr_FR.UTF-8); Calc: group
le 01 juillet 2017 à 07:22
Bonjour,

De toute évidence, si la précédente version ne fonctionne plus non plus, c’est que le problème vient de votre installation.
Apparemment, LibreOffice vous dit qu’il ne peut pas charger Python. Du coup, Grammalecte ne peut pas fonctionner.

Votre mise à jour de LibreOffice a probablement cassé quelque chose dans vos dépendances logicielles. Le problème vient sans doute de votre distribution Linux.
le 01 juillet 2017 à 09:08
Disposant d'une sauvegarde antérieure, j'ai simplement permuté le profil actuel avec l'ancien et me retrouve, après redémarrage, avec la version 5.17. fonctionnelle de Grammalecte.

Je ne sais pas ce qui n'a pas fonctionné. Je ne pense pas que ça vienne de LO mais peut-être d'une mise à jour d'un paquet Python. Dans l'immédiat, faute d'être sûr, je ne fais pas encore la mise à jour de Grammalecte.
le 01 juillet 2017 à 18:59
S’il suffit de permuter le profil pour que ça fonctionne, c’est probablement que le profil s’est corrompu lors de l’installation de la nouvelle version de Grammalecte. (Ou bien que ça vient de la mise à jour vers LO 5.3.4 qui vient de sortir.)

Quoi qu’il en soit, la purge du profil + la réinstallation de Grammalecte devrait régler le problème.
Ce n’est pas un problème de dépendances.
le 01 juillet 2017 à 19:08
En comparant les deux profils, je constate une énorme différence de taille: celui qui est fonctionnel (désormais réinstallé) fait 50 mégas, le "corrompu" 230 mégas. La différence provient notamment de deux fichiers tmp hypertrophiés , l'un placé dans "uno packages", l'autre dans "extensions".

Un réglage du logiciel rsync utlisé pour la sauvegarde permet de faire abstraction des dossiers tmp.
le 02 juillet 2017 à 07:14

Notification par e-mail    0