OK
AJAX error!

Les forumsGrammalectePlugin Sublime Text 3 pour Grammalecte

Plugin Sublime Text 3 pour Grammalecte

Bonjour,

Pour les besoins de mon mémoire j'ai rapidement créé un plugin de Grammalecte pour Sublime Text 3. Il suffit de cloner le dépôt Git dans le dossier Package de Sublime et d'avoir `grammalecte-cli.py` présent dans le path de sa machine pour pouvoir utiliser le plugin.

Les détails sont ici : github.com…
Le plugin est sous license MIT et sera bientôt disponible sur Package Control.

C'est encore une version expérimentale, les pertes de données sont possibles.
Il est malgré tout, très utilisable à l'heure actuelle.

Toutes les contributions sont les bienvenues.

Bien à vous,
Antoine
le 10 mai 2018 à 22:27
Bonjour,

Merci pour votre plug-in. Dès que vous le jugerez utile, je créerai un lien qui pointe vers la page de votre projet.

Est-ce SublimeText qui limite l’affichage de plus d’une suggestion de correction ? C’est une limitation un peu étonnante.
le 11 mai 2018 à 10:16
Bonjour,

Je pense qu'il est préférable que je travaille encore un peu afin de le rendre stable, j'attends aussi son acceptation sur la plateforme de gestion de paquets de Sublime Text.

C'est mon plug-in qui limite pour le moment le nombre de suggestions affichées, je n'ai pas encore trouvé de moyen d'en afficher un nombre arbitraire sans d'importantes duplications de code.
Je pense pouvoir également lever la limitation qui m’empêche de gérer des erreurs superposées, c'est une question de logique.

J'aimerais inclure Grammalecte dans le paquet Sublime Text, quelle serait la meilleure solution technique ? Je pense que la licence GPL de Grammalecte m'y autorise à condition que j'identifie Grammalecte comme licencié sous GPL, est-ce correct ?
le 11 mai 2018 à 16:49
Vu que le menu contextuel est déjà assez chargé, il est peut-être préférable d’afficher les suggestions dans un sous-menu, si du moins c’est possible. À vous de voir.

Je pense que la licence GPL de Grammalecte m'y autorise à condition que j'identifie Grammalecte comme licencié sous GPL, est-ce correct ?


Oui.
le 12 mai 2018 à 08:14

Notification par e-mail    0