OK
AJAX error!

Les forumsGrammalectePlugin VIM ne fonctionne pas [Windows]

Plugin VIM ne fonctionne pas [Windows]

Bonjour,

Je viens de passer sur VIM et souhaiterais me libérer d'avoir à copier-coller dans MSWord uniquement pour utiliser son correcteur orthographique.
J'utilise Windows 10. J'ai installé le plugin Grammalecte. grammalecte-cli.py fonctionne sous DOS mais pas sous VIM.
Voici le message:

Error detected while processing function <SNR>15_GrammalecteCheck:
Line 28:
Command [python3 C:\Python37\Scripts\grammalecte-cli.py -f C:\Users\perubu\AppData\Local\TempVIA1BBE.tmp -roff apostrophe_typographique apostrophe_typographique_après_t espaces_début_ligne espaces_milieu_ligne espaces_fin_de_ligne esp_début_ligne esp_milieu_ligne esp_fin_ligne esp_mélangés2 typo_points_suspension1 typo_tiret_incise nbsp_avant_double_ponctuation nbsp_avant_deux_points nbsp_après_chevrons_ouvrants nbsp_avant_chevrons_fermants1 unit_nbsp_avant_unités1 unit_nbsp_avant_unités2 unit_nbsp_avant_unités3 -j -cl -owe -ctx 2> C:\Users\perubu\AppData\Local\Temp\VIB1BBF.tmp] failed with error: 1

J'utilise Python 3.7 et VIM 8.1.784

Toute suggestion serait bienvenue,

Salutations, --PereUbu
le 21 janvier 2019 à 03:55
Bonjour,

Je n’utilise pas Vim, alors je ne sais pas. Mais le script est-il bien adapté pour Windows ?
Si je tape “python3” dans une console sur Windows, celui-ci ne sait pas ce que c’est. Sous Windows, la commande, c’est juste “python”.

Et y a-t-il bien le script à l’emplacement C:\Python37\Scripts\grammalecte-cli.py ?
Le fichier en paramètre est-il bien présent ?

À mon avis, il faut demander à l’auteur du plug-in si son script est bien adapté pour Windows : github.com…
le 21 janvier 2019 à 10:07

Notification par e-mail    1