OK
AJAX error!

Les forumsGrammalecteChoix du dictionnaire "réforme 1990" identique au choix "toutes variantes"

Choix du dictionnaire "réforme 1990" identique au choix "toutes variantes"

Bonjour.

J'ouvre ce sujet ici suite à ce sujet ouvert sur le forum OpenOffice:
forum.openoffice.org…

En résumé, sur ma configuration comme sur celle de l'auteur du sujet sur OpenOffice, le choix du dictionnaire "réforme 1990" est identique au choix du dictionnaire "toutes variantes", tout au moins pour le mot "maître": le dictionnaire "réforme 1990" accepte les deux orthographes "maitre" et "maître" alors qu'il ne devrait accepter que la première. En fait, le choix du dictionnaire "réforme 1990" semble aussi activer le dictionnaire "classique", à moins que ce soit LibreOffice qui active systématiquement le dictionnaire "classique". Olivier a répondu qu'il n'observait pas ce comportement sur sa configuration.

Je rappelle ma configuration:
LibreOffice 6.0.7.3 version des dépôts sur Linux Mint 19.1 x64, et la dernière version Grammalecte 1 installée.

Si vous pouviez m'indiquer où commencer à chercher dans le dossier de l'extension, où s'effectue le choix du dictionnaire, je pourrais fouiller un peu pour essayer de localiser le problème ...
le 28 avril 2019 à 17:04
Bonjour,

Je suis celui qui vous répondais sur le forum.
Les dictionnaires utilisés sont dans le dossier _dictionaries du dossier grammalecte.

Le réglage est lu avec le fichier Graphspell.py.
le 29 avril 2019 à 13:33
Bonjour.

Merci pour l'info, je vais essayer de décortiquer ça et je vous ferai part du résultat de mes élucubrations si j'arrive à quelque chose.

Personnellement, le problème ne me gêne pas car je reste résolument "classique" avec l'orthographe, mais ça m'intrigue. :)
le 29 avril 2019 à 13:52
Vérifiez quand même que vous n’avez pas des mots classiques dans un dictionnaire personnalisé de LO ou un autre dico annexe.
le 29 avril 2019 à 16:15
Bonjour.

Je n'ai rien trouvé d'anormal dans les dossiers de l'extension. J'ai donc fouillé dans les paramètres linguistiques des options de LibreOffice et j'ai trouvé la solution, décrite ici:

forum.openoffice.org…

Dans ma version LibreOffice 6.0.7.3 des dépôts Linux, le vérificateur orthographique Hunspell est activé par défaut. Sa désactivation rétablit le comportement attendu par le choix des dictionnaires dans Grammalecte: avec le choix du dictionnaire "réforme 1990", seule la nouvelle orthographe est acceptée.

Reste à déterminer si la conservation de l'activation de Hunspell par défaut malgré l'installation de Grammalecte est propre aux versions des dépôts Linux ou si elle concerne aussi la version officielle pour Linux. Je ferai un test dans quelques jours sur un autre PC...

A+
le 30 avril 2019 à 14:05
Attention, ça devient subtil.

Grammalecte installe lui aussi des dictionnaires pour Hunspell, donc ce n’est pas spécialement anormal.

Dans Grammalecte, il y a deux sortes de dictionnaires :
— les dictionnaires pour Graphspell (des dictionnaires binaires indexables utiles au correcteur grammatical et orthographique),
— les dictionnaires pour Hunspell (le correcteur orthographique de LibreOffice).

Normalement, c’est-à-dire si les réglages de Grammalecte sont pris en compte comme il faut :
— Graphspell est utilisé pour toutes les locales francophones (sauf Monaco [fr_MC]),
— Hunspell est utilisé pour la locale francophone Monaco [fr_MC].

La raison de ce réglage, c’est que ça permet d’utiliser le correcteur orthographique Hunspell si besoin (voir les options de Grammalecte).

Pour voir quels dictionnaires sont utilisés pour votre locale, il faut cliquer sur Éditer et sélectionner la locale idoine.
le 30 avril 2019 à 14:31
Euh... là, ça commence à me dépasser.

J'ai refait un essai avec un profil LibreOffice vierge. Voici l'état des paramètres linguistiques pour le Français avant et après installation de Grammalecte :

- avant installation de Grammalecte: Hunspell est activé dans toutes les versions du Français.

- après installation de Grammalecte
a) versions africaines: Hunspell n'est plus affiché, Graphspell est affiché et activé.
b) versions européennes y compris le Canada, sauf Monaco: Hunspell et Graphspell sont tous les deux affichés et activés.
c) version Monaco: seul Hunspell est affiché et activé.

Pour le problème posé sur le forum OpenOffice, je pense que la désactivation de Hunspell devrait correspondre au souhait de l'auteur. Mais pour aller plus loin, je vous passe le relais parce que j'ai atteint mes limites. ;)

A+

le 30 avril 2019 à 15:05
C’est probablement la distribution Linux qui active des versions de Hunspell pour les locales européennes.

Mais je ne suis pas mieux armé que vous pour savoir ce que font les distributions. Moi, je me contente d’utiliser l’interface de programmation de LibreOffice. Ce n’est pas nouveau que les distributions ont tendance à ignorer ce que font les dévs des logiciels pour faire leur propre cuisine.

Mais oui, désactiver Hunspell devrait résoudre le problème.
le 30 avril 2019 à 15:10
D'accord, on va dire que c'est résolu.

Mais dans quelques jours, je ferai l'essai avec une version officielle de LibreOffice sur un autre PC, et je vous ferai part du résultat.

A+
le 30 avril 2019 à 15:12
J’ai ajouté un avertissement pour les utilisateurs de Linux dans l’extension pour LO.
le 01 mai 2019 à 10:54
Bonjour.

Pour en terminer avec ce sujet, j'ai fait un dernier essai avec la version LibreOffice 6.0.7.3, mais avec la version Linux officielle téléchargée sur les archives du site LibreOffice après désinstallation de la version des paquets Linux Mint: même comportement, le choix du dictionnaire "réforme" accepte toujours les deux orthographes !

Avec cette version officielle, on peut voir dans le gestionnaire des extensions qu'un dictionnaire français est installé et verrouillé. Pour le désinstaller, j'ai supprimé le paquet correspondant à l'aide du gestionnaire de paquets: il n'apparaît plus dans les extensions, mais ça ne change rien au comportement de Grammalecte, le dictionnaire "réforme" acceptant toujours les deux orthographes.

En résumé, à moins que je m'y sois mal pris et que j'aie oublié de désinstaller certains paquets de la distribution Linux Mint, ce problème semble affecter les versions Linux officielles et ne devrait donc pas être dû au bricolage des distributions Linux. Pour confirmer, ce serait bien si quelqu'un pouvait faire un test avec une version Linux officielle plus récente.
le 01 mai 2019 à 16:01
Bonjour,

Je suis sur une Mageia 6, le paquet Libre Office de la distrib est la version 6.1.5.2.
Monaco : Hunspell est activé seul.
France : Graphspell et Hunspell sont activés
Toutes les autres version de Français, seul Graphspell est activé.

Effectivement pour fr-FR, lorsque les deux dictionnaires sont activés, les deux orthographes sont considérées comme valides.
Néanmoins en décochant Hunspell pour fr-FR (il n'y a même pas besoin de redémarrer Writer) seul la graphie correspondant au dictionnaire choisi via le menu Grammalecte est reconnue.

Pour conclure Hunspell est activé par défaut. C'est normal c'est lui qui sert de dictionnaire pour l'ensemble de la distribution (une seule installation auquel toutes les appli. font appel (la version 5.7 de fr_FR.dic et fr_FR.aff de dicollecte est installée dans /usr/share/hunspell). Deux dictionnaires activés en même temps dans Libo -> Problème.

Quand on désactive Hunspell dans Libre Office (via outil -> Options-> Paramètres Linguistiques -> Éditer (les modules de langues) -> Choix de "Français (France)" dans la liste -> décochage de Hunspell, le fonctionnement (via Graphspell donc) est celui attendu (classique, réforme ou toutes variantes).

Après installation de Grammalecte, les 3 versions du dictionnaires (+ la Moderne) sont dans mon profile LibO, mais pas la version Hunspell (pas de fr.dic ni de fr_FR.dic). J'imagine donc qu'il utilise toujours celles de usr/share/hunspell.

Cette recherche m'a permis de voir qu'il y a 15 fois le dictionnaire Dicollecte dans mon profile utilisateur : 1 pour Thunderbird, une pour Firefox, une pour PaleMoon (vieille version de Dicollecte puisque PM a choisi de ne pas passer en WebExtension) et 4x3 pour LibO, classique, réforme, moderne et toutes variantes trois fois chacune. Il semble que Libo ne fasse pas de ménage lorsqu'on met à jour une extension (ou est-ce l'extension qui ne lui dit pas ce qu'il faut faire ?)
Question : L'installateur ne pourrait-il pas mettre les dictionnaires dans ~/.config/grammalecte par exemple et ensuite créer des liens dans les profiles de chaque appli ?

C'était mes 2 cents.
le 02 mai 2019 à 15:16
LibreOffice gère lui-même l’installation et la désinstallation des fichiers du profil.
À mon avis, c’est un point sur lequel les dévs de LO devraient se pencher, car c’est un bordel sans fin, on n’y comprend pas grand-chose, et il y a souvent des problèmes.

Moi qui installe et désinstalle sans cesse les builds de Grammalecte, je me retrouve avec un profil de plusieurs gigaoctets régulièrement. Alors je purge manuellement de temps en temps.

Question : L'installateur ne pourrait-il pas mettre les dictionnaires dans ~/.config/grammalecte par exemple et ensuite créer des liens dans les profiles de chaque appli ?


Il n’y a pas d’installateur dans les extensions. C’est LibreOffice qui installe. Nous n’avons pas la main sur cette affaire.
le 03 mai 2019 à 09:12

Admin :
J’ai ajouté un avertissement pour les utilisateurs de Linux dans l’extension pour LO.


Excellente idée, mais il est où? Je viens de réinstaller Grammalecte et je n'ai rien vu...
le 05 mai 2019 à 12:39
Il faut cliquer sur le petit bouton d’information à côté de “Orthographe”.
le 05 mai 2019 à 12:47

Notification par e-mail    0