OK
AJAX error!

Les forumsGrammalecte[Firefox] ne fonctionne pas dans support.mozilla.org

[Firefox] ne fonctionne pas dans support.mozilla.org

Bonjour,

Est-ce normal que je n'ai jamais pu utiliser Grammalecte sur Firefox Quantum (57+) dans les outils de traduction du site support.mozilla.org… ? Pas de bouton sur les formulaires et le menu contextuel est inopérant. Ce site fonctionne avec Grammalecte sur Firefox 56-.

J'ai essayé sans succès avec un profil vierge.

J'ai essayé en vain sur Windows 7 et 10, ainsi que sur Ubuntu.

le 06 juillet 2019 à 17:52
Je crois que ce « problème » ne vient pas de Grammalecte mais de Firefox. L’exécution de toutes les web-extensions pouvant interagir avec la page semble désactivé sur tous les sites appartenant à Mozilla…
le 06 juillet 2019 à 18:31
Sur Mozilla.org ça marche. Normalement, les WebExtensions sont bloquées sur les pages internes de Firefox et sur AMO (addons.mozilla.org).
le 06 juillet 2019 à 19:07
Le code est le même pour tous les sites. Si ça ne fonctionne pas, c'est que quelque chose interfère avec l'extension. Ici, j'ai le sentiment que les content-scripts ne fonctionnent pas. C'est, j'imagine, une volonté délibérée de Mozilla.
Je ferai un test plus poussé de retour chez moi dans quelques jours.
le 07 juillet 2019 à 06:27
Il n'est pas sûr du tout que ce soit volontaire. Le site est vieillissant et assez bogué. À noter que l'extension y fonctionne sur Chrome.
le 07 juillet 2019 à 14:15
C'est le même code dans l'extension pour Chrome.
C'est donc Firefox, je présume, qui bloque les content-scripts, mais je ne pourrais m'en assurer que dans quelques jours.
le 07 juillet 2019 à 14:31
Vérification faite, c’est bien ça.
Firefox ne lance pas les content-scripts dans support.mozilla.org. Faut rapporter le “bug” chez Mozilla.
le 10 juillet 2019 à 14:33

Notification par e-mail    0