OK
AJAX error!

Les forumsGrammalecteNotification de mise à jour de Grammalecte dans LibreOffice

Notification de mise à jour de Grammalecte dans LibreOffice

Bonjour,

Pour savoir si une nouvelle version de Grammalecte est disponible, il faut aller sur le site officiel.

Pourtant, dans LibreOffice, en allant dans Outils/Gestionnaire des extensions puis en cliquant sur Vérifier les mises à jour, on devrait être notifié d'une nouvelle version, et ce n'est jamais le cas.

Est-ce un oubli de conception ? Un problème avec LibreOffice ?

Ce phénomène se produit aussi bien sous Windows que sous Linux.
le 11 septembre 2019 à 21:21
Bonjour,

Ce n’est que depuis très récemment que j’ai remis en marche le système de notification et de téléchargement des mises à jour de Grammalecte pour LibreOffice.

Encore faut-il que je l’utilise. Or, la dernière version pour LO posant de menus problèmes, je n’ai pas encore utilisé le système pour lancer la notification.
le 12 septembre 2019 à 08:16
J'ai tenté une mise à jour de l'extension dans LibreOffice Version: 6.2.7.1 (x64) qui renvoyait une erreur pythonloader.py etc...
j'ai supprimé Grammalecte des extensions pour la ré-installer et voici ce que cela donne :
"Vous êtes sur le point d'installer la version 6.4.3 de l'extension 'Grammalecte (pack)'.
La version antérieure 0, nommée 'LibreOffice_Grammalecte-fr v140.oxt', est déjà installée.
Cliquez sur 'OK' pour remplacer l'extension installée.
Cliquez sur 'Annuler' pour interrompre l'installation.
[OK]... "an error occured..." :-(
merci de m'indiquer ce qui pourrait bloquer l'installation.
le 06 octobre 2019 à 18:06
Faites un effaçage partiel de profil. Supprimez les sous-dossiers : extensions et uno_package.
le 06 octobre 2019 à 18:18
Avec la sortie de la version 1.5.0 de Grammalecte, le problème demeure.

Dans le gestionnaire des extensions (LibreOffice 6.2.5.1), j'ai toujours le message Aucune mise à jour n'est disponible, alors que j'ai la version 1.4 d'installée.
le 09 octobre 2019 à 21:31
Oui, je vois pourquoi. Erreur de ma part, mais je ne peux pas le corriger.
En fait, ça vient du numéro de version de l’extension qui correspond au numéro du dictionnaire et non au numéro de Grammalecte. Si le numéro du dictionnaire n’est pas mis à jour, la mise à jour n’est pas considérée comme nouvelle pour le système.
le 09 octobre 2019 à 22:24
Question stupide : Ya pas moyen de considérer le dictionnaire et Grammalecte comme étant deux extensions différentes liés par une relation de dépendance ?
le 10 octobre 2019 à 04:26
Pour LO, une extension se définit par un identifiant et un numéro de version.
le 10 octobre 2019 à 09:44
Humm je peux me tromper mais je sens le quiproquo.

Est-ce que c'est possible d'avoir :
– Extension 1 : {nom : "Dictionnaire pour correcteur grammatical", version : "6.4.1"}
– Extension 2 : {"Correcteur grammatical Grammalecte", version "1.5.0", dépendances : [{nom : "Dictionnaire pour correcteur grammatical", version : "6.4.1"}]}

Avec si possible les deux inclus dans la même fichier.


Autre possibilité : construire un numéro de version de l'extension qui soit la "somme" des numéros de version du dictionnaire et du correcteur. Si je reprends les numéros de version donnés avant on aurait :
numéro de version de l’extension = "6.4.1" + "1.5.0" = "7.9.1"
Et s'il faut un entier on garde trois chiffres pour chaque morceau : 7009001
le 10 octobre 2019 à 14:11
Laissez tomber. Il faut juste que je me souvienne d’upgrader le numéro de version de Grammalecte et de l’extension à chaque fois, ce que je ne faisais pas forcément jusqu’à présent.
le 11 octobre 2019 à 11:10
Rendez-vous pour la prochaine version alors ! On verra si le message apparaîtra.
le 17 octobre 2019 à 17:03

Notification par e-mail    0