OK
AJAX error!

Les forumsGrammalecteFormateur de texte : options non mémorisées

Formateur de texte : options non mémorisées

Bonjour à tous

Je ne parviens pas à désactiver certaines fonctionnalités du formateur de texte.
Par exemple, si je décoche les signes typographiques et que je clique sur appliquer, lors de la réouverture de cette fenêtre le changement, n’a pas été mémorisé (la case est de nouveau cochée).

Merci d’avance.

Benoît
le 25 septembre 2019 à 14:48
Bonjour,

Sur quel logiciel ?
le 25 septembre 2019 à 14:53
Bonjour

Sous LibreOffice Writer :

Avec : Grammalecte-fr-v1.4.0.oxt

Version: 6.1.5.2
Build ID: 1:6.1.5-3+deb10u3
Threads CPU : 4; OS : Linux 4.19; UI Render : par défaut; VCL: gtk2;
Locale : fr-BE (fr_BE.UTF-8); Calc: group threaded
le 25 septembre 2019 à 15:07
Hmm… vous avez vraisemblablement installé l’extension pour tous les utilisateurs et non pour vous seul, ce qui est, j’imagine, la cause du “dysfonctionnement”, mais c’était en fait voulu ainsi.

Cela dit, en regardant ce vieux code, je m’aperçois que la méthode employée pour sauvegarder les options pourrait être meilleure.
le 25 septembre 2019 à 15:19
Il me semble que Grammalecte n’a pas été installé pour tous les utilisateurs.
Voici quelques tests rapides :
J’ai supprimé : "$HOME/.config/libreoffice"
Puis j’ai ouvert LibreOffice Writer sans rien faire pour recréer "$HOME/.config/libreoffice" et m’assurer que Grammalecte n’est pas listé dans le gestionnaire des extensions.

- Puis j’ai installé Grammalecte avec mon utilisateur (pas en root) en ouvrant le fichier « Grammalecte-fr-v1.4.0.oxt » avec LibreOffice Writer.
- J’ai à nouveau supprimé "$HOME/.config/libreoffice" et essayé l’installation dans le navigateur (firefox) sur "grammalecte.net… qui propose d’ouvrir avec LibreOffice.
- Ressayé (en ayant supprimé $HOME/.config/libreoffice) l’installation avec le gestionnaire des extensions en décochant «Installé pour tous les utilisateurs» et «fourni avec LibreOffice», pour ne lister que l’extension «Installé par l’utilisateur actif», et m’assurer que Grammalecte est la seule extension listée après installation.
Qu’en pensez-vous ?
le 25 septembre 2019 à 17:06
Par contre, je me pose une question sur le chemin de configuration de LibreOffice :
Pourquoi "4" dans : "$HOME/.config/libreoffice/4/user/" ?
Ma version: 6.1.5.2
Pour d’autres options de configuration, Grammalecte trouve le chemin.
...
le 25 septembre 2019 à 17:33
Je viens de m’apercevoir que LO 6.3 ne demande plus, lorsqu’on installe une extension, si elle est pour tous les utilisateurs ou juste pour soi. Donc, ce que j’ai dit précédemment n’a peut-être plus de valeur. Je ne sais pas si c’était déjà le cas avec LO 6.1. (Il y a longtemps, les extensions n’étaient pas forcément installées dans le profil utilisateur.)

Quoi qu’il en soit, dans tous les cas de figure, Grammalecte (ou plutôt Grammalecte à travers Python utilisé par LibreOffice) a besoin des droits d’écriture sur le dossier où est installé Grammalecte. S’il a les droits, les options seront préservées. S’il ne les a pas, elles ne le seront pas.

Attendu que les distributions ont tendance à faire les choses chacune à leur manière, aucune idée si ces droits sont autorisés dans votre cas. Mais c’est ce point particulier qui importe.

Chez moi, ça fonctionne (mais j’utilise Windows et un LO vanilla).
le 25 septembre 2019 à 17:35

Pourquoi "4" dans : "$HOME/.config/libreoffice/4/user/" ?


C’est comme ça pour tout le monde. Ils n’ont probablement pas voulu upgrader le numéro pour des raisons de compatibilité.
le 25 septembre 2019 à 17:36
Désolé, je viens de rééditer mon dernier post à ce sujet, j’aurais du en créer un nouveau, nos idées se sont croisées : «Pour d’autres options de configuration, Grammalecte trouve le chemin.»
Les autres options de configuration de Grammalecte sont préservées.
le 25 septembre 2019 à 17:45
Oui, parce que les autres options ne sont pas sauvegardées de la même manière.
Mais à vrai dire, je me demande bien pourquoi j’ai voulu faire différemment avec le formateur de texte. Il y a forcément une raison, mais impossible de me souvenir laquelle.
Bref, si ça ne me revient pas, je vais utiliser la voie “normale”.
le 25 septembre 2019 à 19:07
Corrigé.
J’ai modifié le mode de sauvegarde des options du formateur de texte, qui est maintenant semblable à celui des autres options.
(Je ne me souviens toujours pas pourquoi j’ai voulu faire différemment.)
le 26 septembre 2019 à 09:33

Notification par e-mail    0