OK
AJAX error!

Les forumsGrammalecteCorrecteur le voit pas de paragraphes dans le courriel de réponse Thunderbird 68

Correcteur le voit pas de paragraphes dans le courriel de réponse Thunderbird 68

J'ai rédigé le message suivant avec Thunderbird 68. Le correcteur détecte bien les fautes.

--Voici une évaluation de grammalecte, une outil de vérification de
grammaire et de langue. Il faut installé le logiciels. --

mais, quand je le transmets à moi et j'ajoute du texte de réponse au message ou non aucun paragraphe est détecté. Si je coupe le texte et je le recopie comme texte simple, le correcteur marche bien. Il semble avoir quelque chose caché dans le format de la réponse (html ?) qui cause le correcteur de ne rien voir ? Pour l'instant je suis pris avec couper et coller comme texte.

Merci

Alyre
le 28 octobre 2019 à 22:49
Je ne suis pas sûr de vous comprendre.
Le texte mentionné en citation n’est pas analysé, c’est ainsi que ça a été voulu.
le 29 octobre 2019 à 09:04
Merci de votre réponse. Voici j'espère une meilleure description des étapes afin de reproduire le problème.



1) Dans Thunderbird rédigez un message à vous qui contient des fautes (j'ai Thunderbird 68, Deepin Linux )
2) Utilisez le correcteur afin de vous assurer qu'il marche
3) Envoyez le message à vous
4) À la réception ouvrez le message
5) Choisissez l'option répondre au message
6) Ajoutez ou non un petit brin de texte en avant du texte originel
6) Vérifiez le texte de nouveau avec le correcteur
7) Dans mon cas le correcteur ne voit rien du texte entier (0 paragraphes s'affiche en bas)
8) Sélectionnez le texte entier et le coupiez du message
9) Remettez le même texte, mais sans format (texte simple)
10) Dans mon cas le correcteur marche de nouveau
11) Conclusion, il y a quelque chose que Thunderbird place dans la structure du format d'une réponse à un courriel qui change le fonctionnement du correcteur. La conversion du message à texte simple, rectifie le problème.

Toutes mes réponses aux courriels ont ce problème en absence d'étapes 8 et 9.

Cordialement,


Alyre




le 29 octobre 2019 à 17:40
Quand vous écrivez vos réponses avant le message cité, il faut modifier dans les paramètres de chaque compte une option dans [Rédaction et adressage] :
Pour [Lors de la rédaction], choisissez [la réponse commence avant la citation].
Si vous ne le faites pas, le correcteur ne voit pas le texte écrit avant la citation.

C’est assez étrange, mais je n’y peux pas grand-chose. Le format de rédaction d’un mail, même au format texte, est une espèce de HTML mal foutu.
Quand vous copiez-collez, vous altérez probablement la structure HTML sous-jacente, ce qui peut la rendre visible au correcteur, j’imagine.
le 29 octobre 2019 à 18:39
Bonjour,

Une solution facile à implémenter, merci pour le remède!

Alyre

le 29 octobre 2019 à 21:48

Notification par e-mail    0