OK
AJAX error!

Les forumsGrammalecteGrammalecte pour Thunderbird 78 - Vérification des réponses

Grammalecte pour Thunderbird 78 - Vérification des réponses

Outil génial. Marche parfaitement pour les nouveaux messages. Mais pas pour les réponses (il voit uniquement la signature).
J'ai pourtant :
coché Citer le message original dans la réponse
choisi La réponse commence avant la citation
choisi La signature est sous ma réponse

Merci d'avance de votre aide.
Jean-Pierre
le 12 octobre 2020 à 15:27
Chez moi, ça fonctionne. Puis-je avoir une capture d’écran aussi complète que possible, s. v. p. ?
Vous pouvez utiliser Framapic : framapic.org…
le 12 octobre 2020 à 15:36
En fait, j'ai un fonctionnement aléatoire. Même pour les nouveaux messages. Voici un exemple où j'ai fait des fautes volontairement dans les mots mis en gras.
Grammalecte apparemment ne scanne pas ces paragraphes.

Voir :
1drv.ms…
1drv.ms…

Merci de votre aide

le 14 octobre 2020 à 09:51
Étonnant, mais je constate sur votre écran une différence de taille : votre éditeur contient deux onglets : “Éditer” et “HTML”. J’ignore d’où ça vient et je présume qu’il s’agit d’une autre extension qui permet cela.

Pouvez-vous envoyer une capture d’écran du HTML de votre message ?

Pouvez-vous essayer de faire fonctionner Grammalecte après avoir (temporairement) désinstallé l’extension qui créent ces onglets ?
le 14 octobre 2020 à 10:43
Bonjour,

La désactivation du module complémentaire (très pratique) ThunderHTMLedit ne chage rien.

Voila la source HTML du message.


<!DOCTYPE html><html>
<head>
<meta http-equiv="content-type" content="text/html; charset=">
</head>
<body>
<font face="Calibri">Bonjour Mesdames,<br>
<br>
Désolé de cet afflux de messages, mais le vote par correspondance nous oblige à revoir avec précision le texte des
<b>résolution </b>pour permettre un vote sans ambiguïté. Dans le passé, beaucoup d'ajustements des résolutions
avaient lieu en séance, ce qui rend invalide les votes par correspondance.<br>
<br>
La résolution 25 telle que rédigée, ne permet pas un vote simple "Pour"/"Contre". Par ailleurs, le conseil
syndical considère qu'il est nécessaire de revoir les <b>entreprise </b>avant de finaliser notre recommandation.
<br>
</font>
<div class="moz-signature"><br>
-- <br>
Cordialement<br>
<font color="#25597F">
<!-- Bahama Blue --> <b>Jean-Pierre Lévy</b><br>
</font></div>
<div id="grammalecte_menu_main_button_shadow_host" style="width: 0px; height: 0px;"></div>
</body>
</html>



Merci d'avance. Jean-Pierre
le 14 octobre 2020 à 13:32
Étrange, le HTML de vos mails ne semble pas conforme à l’usage.

Chez moi, quand j’écris un mail, ça ressemble à ceci :

<!DOCTYPE html><html>
<head>

<meta http-equiv="content-type" content="text/html; charset=">
</head>
<body>
<p>Bonjour,</p>
<p>Ceci est un test.</p>
<p>Nouveau paragraphe.</p>
<p><br>
</p>
<p>Salutations.<br>
</p>
<div id="grammalecte_menu_main_button_shadow_host" style="width: 0px; height: 0px;"></div>
</body>
</html>



Contrairement aux vôtres, il y a des balises <p> dans mes mails (pour chaque paragraphe). Chez vous, tout votre mail est écrit dans une balise <font-face>.
Et comme Grammalecte n’analyse que le contenu des balises <p>, <li>, <h1>…<h6>, il est “normal” qu’il ne voit rien dans vos messages. Il faudrait comprendre pourquoi vos mails sont constitués ainsi, ce qui ne semble pas normal. Y a-t-il des modèles HTML obsolètes dans Thunderbird ?
le 14 octobre 2020 à 14:16
J'ai essayé de mieux cerner la cause du problème qui semble liée aux balises HTML.

Quand j'enlève la balise <font face="Calibri">, le texte est analysé, mais Grammalecte ignore le texte entre <b> et </b>.

Y-a-t'il un paramètre que j'ai oublié pour demander l'analyse correcte d'un texte HTML ?

Jean-Pierre
le 14 octobre 2020 à 14:21
Non, pas à ma connaissance.

Accessoirement, Grammalecte analyse aussi les nodes sans tag situés en dehors des balises usuelles, parce que ce sont des nodes de texte. Si le contenu de <b> est ignoré, c’est parce que <b> n’est pas une balise de paragraphe et ce n’est pas un node sans tag.

Mais vous ne devriez même pas avoir à vous soucier de ça.

En théorie, les mails sont constitués avec essentiellement des balises <p>, <h1>…
Il faut comprendre pourquoi vos mails ne sont pas constitués normalement chez vous. Tout le reste, ce n’est que de la magouille. Vous n’avez pas à éditer le HTML pour satisfaire le correcteur.
le 14 octobre 2020 à 15:02
Et donc que dois-je faire pour que "cela marche" ?
le 14 octobre 2020 à 17:31
Je sèche un peu sur la question… Je peux peut-être essayer d’améliorer Grammalecte pour gérer ça, mais ça me paraît compliqué, aventureux et pas forcément fiable.

Pour les raisons qui provoquent ce comportement inattendu, je vois plusieurs possibilités :
— profil corrompu,
— modèles de mails obsolètes,
— interférence d’une autre extension peut-être ?

Ce que je peux vous suggérer c’est d’expliquer le problème sur le forum dédié à Thunderbird :
forums.mozfr.org…

Là-bas, ils connaissent probablement mieux que moi les arcanes de Thunderbird et quelqu’un aura peut-être une idée.
Si vous ouvrez un fil de discussion là-bas, postez le lien ici. J’ai un compte là-bas et j’interviendrai si besoin.
le 14 octobre 2020 à 17:54
Voila mon post sur le forum Thunderbird.

forums.mozfr.org…
le 14 octobre 2020 à 21:01
Le problème est lié à la manière dont Grammalecte analyse le texte HTML. In cherche des balises <p> et </p>.
Ces balises ne sont placées par Thunderbird que si l'on a sélectionné :

"Utiliser le format paragraphe à la place du format texte principal par défaut", située dans : menu Thunderbird / outils / options / volet gauche : rédaction / volet droit : style HTML
le 15 octobre 2020 à 12:56
J’ai indiqué ce point sur la page de téléchargement de l’extension.
Malheureusement, il n’est pas possible de savoir si cette option est cochée ou non, mais je vais essayer de signaler ce point dans l’extension elle-même.
le 15 octobre 2020 à 13:54
Je suis en train de réaliser que de nombreuses balises HTLM conduisent à ignorer une partie significative du texte. Je n'en ai pas fait l'inventaire, mais je viens de tomber sur "Blockquote" qui correspond à une simple indentation du texte. Je ne sais pas s'il y a d'autres restrictions.

C'est dommage pour un outil qui est excellent pour la vérification grammaticale.
Cordialement
le 16 octobre 2020 à 21:48
Vous pouvez en faire la liste si vous le souhaitez, car cela peut se compléter (du moment qu’il s’agit d’une balise “bloc”), mais le parti pris c’est de ne pas analyser le message auquel l’utilisateur répond.
le 17 octobre 2020 à 08:45
Je comprends le parti pris de ne pas analyser la réponse. Mais Thunderbird utilise Blockquote pour "augmenter le retrait (vers la droite)" quand on rédige un message et que l'on veut un peu travailler la présentation. Effectivement, ce n'est pas la seule manière de faire un retrait, j'ai testé un autre éditeur HTML et lui utilise "paddingleft". Mais Grammalecte est pour Thunderbird.
J'ai testé le même retrait sur LibreOffice et dans ce cas Grammalecte analyse correctement.

Si je trouve d'autres cas de balise qui pose problème, je le signalerai.
Cordialement.
le 17 octobre 2020 à 09:09

Notification par e-mail    1