OK
AJAX error!

Les forumsÀ propos du sitegrammalecte ne me marche pas

grammalecte ne me marche pas

Bonjour a toute la communaute et mes meilleurs voeux pour 2021
Je met un petit post, car j'ai voulu installer grammalecte sur mon portable acer achete ici ou je suis en Espagne il y a 2 ou 3 ans. Tout l'interieur est en langue espagnole, et j'ai Open Office. Mais le correcteur d'ortographe francais n'existe pas d'origine. J'ai voulu installer grammalecte que j'ai pris sur le site 01 informatique, et apparemment j'ai reussi apres a obtenir une correction, mais....pour langue espagnole sur un texte que j'avais ecris en francais. C'est genant. Or moi ce que je pensais reussir, c'est que s'installe directement apres le lancement du telechargement, le correcteur orthographique sur mon Open, mais en langue francaise.
Quelqu'un pourrait il me faire une suggestion, et eventuellent m'expliquer ce qui se passe.
Je vous remercie infiniment.


excusez mes fautes de ponctuation, mais mon clavier n'est pas francais.
le 29 décembre 2020 à 19:53
L’usage de LibreOffice est recommandé par rapport à OpenOffice qui est devenu propriétaire. Je vous invite à réessayer avec la dernière version de LibreOffice à télécharger sur le site officiel (fr.libreoffice.org…) et en utilisant la dernière version de Grammalecte disponible sur ce site (grammalecte.net…)
le 29 décembre 2020 à 23:09
Bonjour,

Le problème de tous ces sites de téléchargement, c’est qu’ils font du mauvais travail.
Ils devraient signaler que la version de Grammalecte qu’ils proposent ne fonctionne qu’avec LibreOffice, pas avec OpenOffice.

Le développement d’OpenOffice est quasiment à l’arrêt depuis de nombreuses années et le logiciel est en passe de devenir obsolète.

Donc, oui, comme le dit Naheulf, utilisez LibreOffice.
le 30 décembre 2020 à 14:16
Oups ... passer à LibreOffice? je veux bien sauf que certaines fonctionnalités essentielles pour moi ne sont pas présentes dans LibreOffice alors quelles le sont dans openoffice (par. ex copier directement la mise en page d'une page WEB)
pourquoi ce besoin? je développe mes textes sous VIM avec asciidoc et je génère parfois des documents HTML ... quand un éditeur me demande un format .doc (Grrrrrr!) je copie dans open-office mon document ainsi généré (qui est retranscrit en .doc: bonjour l'usine à gaz)
donc oui je n'arrive pas à faire fonctionner grammalecte ni sur open office ni d'ailleurs sur VIM: (il me dit grammalecte#Check not found). je crois pourtant avoir vérifié plusieurs fois les installations (selon le mode d'emploi sur github) mais il doit manquer qqch.
le 22 janvier 2021 à 14:45
La dernière version de Grammalecte compatible avec OpenOffice, c’est la 0.4.10.7…
Les autres versions de Grammalecte nécessite Python 3.3+ et OpenOffice utilise l’obsolète Python 2.7.

Par ailleurs, le développement d’OpenOffice est quasiment à l’arrêt par rapport à LibreOffice. Il y a quelques années, le rapport entre les deux logiciels en nombre de commits était environ ×50, et pour autant que je sache la situation n’a pas évolué. OpenOffice n’avance plus vraiment que pas à pas, probablement uniquement pour que la fondation Apache continue de recevoir de l’argent. OpenOffice n’est plus qu’un genre de logiciel zombie, maintenu à bout de bras par un trop petit nombre de dévs.

Depuis le 1ᵉʳ janvier 2021 :
— 753 commits pour LibreOffice.
— 11 commits pour OpenOffice.

Ça fait des années que c’est comme ça.

Bref, pour nous, OpenOffice, c’est mort. De toute façon, il est hors de question de revenir à Python 2.7.
le 22 janvier 2021 à 21:10
Pour le plugin Vim, depuis deux révisions certaines fonctions présentes dans le fichier /plugin/Grammalecte.vim on été externalisés dans le fichier /autoload/grammalecte.vim. (On notera au passage la différence de casse entre les deux noms de fichiers.) Mais le fichier d'aide ne reflète pas ces changements. Avez-vous pensé à les répercuter lors de votre installation ?

Si besoin, j'ai demandé à mettre à jour la doc d'installation du plugin vim ici : github.com…
le 24 janvier 2021 à 09:56

je n'arrive pas à faire fonctionner grammalecte ni sur open office ni d'ailleurs sur VIM



Il s'agit probablement du même problème que j'ai rencontré quand j'ai
essayé le greffon vim-Grammalecte avec Grammalecte-v2.0.0.

En bref, Grammalecte >= v2.0.0 exige Python-3.7+ mais Ubuntu-18.04.5
vient avec Python-3.6.9.

Pour la solution, voir grammalecte.net…
le 24 janvier 2021 à 11:59

Notification par e-mail    0